games-util/mcdreforged: add 2.13.0-r1, drop 2.13.0
* skip environment check * fix qa
This commit is contained in:
parent
4e61d0991e
commit
39efcc8461
19
games-util/mcdreforged/files/mcdreforged-2.13.0-fix-qa.patch
Normal file
19
games-util/mcdreforged/files/mcdreforged-2.13.0-fix-qa.patch
Normal file
@ -0,0 +1,19 @@
|
||||
--- a/setup.py 2024-07-13 19:24:16.001303928 +0800
|
||||
+++ b/setup.py 2024-07-13 19:24:40.679695152 +0800
|
||||
@@ -1,6 +1,6 @@
|
||||
import os
|
||||
|
||||
-from setuptools import find_packages, setup
|
||||
+from setuptools import find_namespace_packages, setup
|
||||
|
||||
from mcdreforged.constants import core_constant
|
||||
|
||||
@@ -65,7 +65,7 @@
|
||||
author=AUTHOR,
|
||||
python_requires=REQUIRES_PYTHON,
|
||||
project_urls=PROJECT_URLS,
|
||||
- packages=find_packages(exclude=['tests', '*.tests', '*.tests.*', 'tests.*']),
|
||||
+ packages=find_namespace_packages(exclude=['tests', '*.tests', '*.tests.*', 'tests.*']),
|
||||
include_package_data=True,
|
||||
install_requires=REQUIRED,
|
||||
classifiers=CLASSIFIERS,
|
@ -0,0 +1,12 @@
|
||||
--- a/mcdreforged/mcdr_server.py 2024-07-13 18:08:11.731580563 +0800
|
||||
+++ b/mcdreforged/mcdr_server.py 2024-07-13 18:10:26.344782844 +0800
|
||||
@@ -83,7 +83,8 @@
|
||||
self.preference_manager: PreferenceManager = PreferenceManager(self)
|
||||
self.__tr = self.create_internal_translator('mcdr_server')
|
||||
|
||||
- self.__check_environment()
|
||||
+ # Skip this to fix environment detection
|
||||
+ # self.__check_environment()
|
||||
|
||||
# --- Input arguments "generate_default_only" processing --- #
|
||||
if args.generate_default_only:
|
@ -33,4 +33,9 @@ RDEPEND="
|
||||
dev-python/wcwidth[${PYTHON_USEDEP}]
|
||||
"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-2.13.0-skip-environment-check.patch"
|
||||
"${FILESDIR}/${PN}-2.13.0-fix-qa.patch"
|
||||
)
|
||||
|
||||
distutils_enable_tests unittest
|
Loading…
x
Reference in New Issue
Block a user