1
0

games-util/mcdreforged: treeclean

This commit is contained in:
Puqns67 2024-12-28 18:43:22 +08:00
parent b1b85e11a5
commit f0861b3967
Signed by: Puqns67
GPG Key ID: 9669DF042554F536
5 changed files with 0 additions and 87 deletions

View File

@ -1 +0,0 @@
DIST mcdreforged-2.13.0.tar.gz 185539 BLAKE2B 46074e4219a766e7e919becb4b363cc113b69b33eb9ab3a4459091b753b4a63c85def09deec83fcada2a8eb965619acfe405ec77d04694a4f41e8c91b093a006 SHA512 8cef237fcd09c886484b08aedc3311a95132c4aafb3fe0885a075867b71db8cf5f13945031d5aa25449d2abce3b8185742ac932dc73e6a58976850d3fca228e3

View File

@ -1,19 +0,0 @@
--- a/setup.py 2024-07-13 19:24:16.001303928 +0800
+++ b/setup.py 2024-07-13 19:24:40.679695152 +0800
@@ -1,6 +1,6 @@
import os
-from setuptools import find_packages, setup
+from setuptools import find_namespace_packages, setup
from mcdreforged.constants import core_constant
@@ -65,7 +65,7 @@
author=AUTHOR,
python_requires=REQUIRES_PYTHON,
project_urls=PROJECT_URLS,
- packages=find_packages(exclude=['tests', '*.tests', '*.tests.*', 'tests.*']),
+ packages=find_namespace_packages(exclude=['tests', '*.tests', '*.tests.*', 'tests.*']),
include_package_data=True,
install_requires=REQUIRED,
classifiers=CLASSIFIERS,

View File

@ -1,12 +0,0 @@
--- a/mcdreforged/mcdr_server.py 2024-07-13 18:08:11.731580563 +0800
+++ b/mcdreforged/mcdr_server.py 2024-07-13 18:10:26.344782844 +0800
@@ -83,7 +83,8 @@
self.preference_manager: PreferenceManager = PreferenceManager(self)
self.__tr = self.create_internal_translator('mcdr_server')
- self.__check_environment()
+ # Skip this to fix environment detection
+ # self.__check_environment()
# --- Input arguments "generate_default_only" processing --- #
if args.generate_default_only:

View File

@ -1,41 +0,0 @@
# Copyright 2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_12 )
inherit distutils-r1 pypi
DESCRIPTION="A rewritten version of MCDaemon, a python tool to control your Minecraft server"
HOMEPAGE="
https://mcdreforged.com/
https://github.com/MCDReforged/MCDReforged
https://pypi.org/project/mcdreforged
"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64"
RDEPEND="
>=dev-python/colorlog-6.4[${PYTHON_USEDEP}]
>=dev-python/colorama-0.4.4[${PYTHON_USEDEP}]
>=dev-python/packaging-23[${PYTHON_USEDEP}]
>=dev-python/parse-1.18[${PYTHON_USEDEP}]
=dev-python/prompt-toolkit-3*[${PYTHON_USEDEP}]
>=dev-python/psutil-5.8[${PYTHON_USEDEP}]
>=dev-python/requests-2.26[${PYTHON_USEDEP}]
dev-python/resolvelib[${PYTHON_USEDEP}]
=dev-python/ruamel-yaml-0*[${PYTHON_USEDEP}]
>=dev-python/typing-extensions-4.6[${PYTHON_USEDEP}]
dev-python/wcwidth[${PYTHON_USEDEP}]
"
PATCHES=(
"${FILESDIR}/${PN}-2.13.0-skip-environment-check.patch"
"${FILESDIR}/${PN}-2.13.0-fix-qa.patch"
)
distutils_enable_tests unittest

View File

@ -1,14 +0,0 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>me@puqns67.icu</email>
<name>Puqns67</name>
</maintainer>
<upstream>
<doc>https://docs.mcdreforged.com/</doc>
<bugs-to>https://github.com/MCDReforged/MCDReforged/issues</bugs-to>
<remote-id type="github">MCDReforged/MCDReforged</remote-id>
<remote-id type="pypi">mcdreforged</remote-id>
</upstream>
</pkgmetadata>